$re = '/(<\w+)(\s*[\w-]+="[^"]+")*(\s*[\w-]+="[^"]+")*(\s*>)|(\w)|(<\/\w+)*(\s*>)/';
$str = '<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<a href="#" data-toggle="modal" data-target="xxxx">xxxx</a>
<a href="#"data-target="#available-assistance" data-toggle="modal"  data-modal="yeah"></a>
<a href="#"data-target="#available-assistance" data-toggle="modal"  data-modal="yeah"></a>
';
$subst = "$1$4$5$6$7";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;