package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)SOL:(\d{4})\s+(.*)\s+,\s+EXPOZITIE (\w{0,2})`)
var str = `* SOL:1201 тут слова строки текста , EXPOZITIE ST * `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}