$re = '/SOL:(\d{4})\s+(.*)\s+,\s+EXPOZITIE (\w{0,2})/m';
$str = '* SOL:1201 тут слова строки текста , EXPOZITIE ST * ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);