package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^][,]+`)
var str = `[CMD1,[CMD2],[CMD3,[CMD4],[CMD5]]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}