$re = '/[^][,]+/m';
$str = '[CMD1,[CMD2],[CMD3,[CMD4],[CMD5]]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);