import re
regex = re.compile(r"CA\s19[-|\s]9\s(\d+)", flags=re.MULTILINE)
test_str = ("CA 19-9 25 U/mL 0 - 35 01\n"
"CA 19 9 25 U/mL 0 - 35 01")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")