re = /CA\s19[-|\s]9\s(\d+)/m
str = 'CA 19-9 25 U/mL 0 - 35 01
CA 19 9 25 U/mL 0 - 35 01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end