import re
regex = re.compile(r"^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])[a-zA-Z0-9]{8,}$", flags=re.MULTILINE)
test_str = ("由大写字母,小写字母,数字组成(每样必须存在一个以上),8位以上。\n"
"lsdkfj0jklj\n"
"8877777889\n"
"DDJJILNHUKJ\n"
"jllskdfjjK8")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")