re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])[a-zA-Z0-9]{8,}$/m
str = '由大写字母,小写字母,数字组成(每样必须存在一个以上),8位以上。
lsdkfj0jklj
8877777889
DDJJILNHUKJ
jllskdfjjK8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end