package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w\s]*)(?:<script.*?\/script>)(.*)$`)
var str = `This is simple html text <script language="javascript">simple simple text text</script> text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}