$re = '/([\w\s]*)(?:<script.*?\/script>)(.*)$/';
$str = 'This is simple html text <script language="javascript">simple simple text text</script> text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);