$re = '/[{youtube ]{9}.+[}]{1}/m';
$str = 'yyyy{{{ bb_}
{{ tbeby@#$} fafasdfasd}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);