package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)&([^&]*thistext[^&]*)&`)
var str = `thisip4:isatextexample&ineed.thistext&TXT:&andthis.idontneed&txt:&test.thistext&`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}