re = /&([^&]*thistext[^&]*)&/m
str = 'thisip4:isatextexample&ineed.thistext&TXT:&andthis.idontneed&txt:&test.thistext&'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end