#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^("[ A-Z0-9:'\-\!\?\%\.,\(\)]+")(\s?([A-Z0-9:'\-\!\?\%\.,\(\)]+\s?")(\s?([ A-Z0-9:'\-\!\?\%\.,\(\)]+\s?")?)?)?"
Local $sString = ""Job" Moesha and Kim land jobs in "market research" at the mall." & @CRLF & _
""Street Fighter: The Legend of Chin-Li " In Bangkok, crime boss Bison "seriously" reconsiders his life choices." & @CRLF & _
""Mike and Me!" A story about a man and a "dog."" & @CRLF & _
"" Did They Care? (Probably not.)" Everyone's wondering about it." & @CRLF & _
""John's " Shopping " Trip " "Jimmy" John Smith goes to "purchase" something." & @CRLF & _
""The " Proper " Use Of Quotes" Here we discuss how "quotes" should be used." & @CRLF & _
""Giving It 100%." All about trying hard." & @CRLF & _
""Mary-Anne, Are You There?" No one can find her."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")