$re = '/^("[ A-Z0-9:\'\-\!\?\%\.,\(\)]+")(\s?([A-Z0-9:\'\-\!\?\%\.,\(\)]+\s?")(\s?([ A-Z0-9:\'\-\!\?\%\.,\(\)]+\s?")?)?)?/mi';
$str = '"Job" Moesha and Kim land jobs in "market research" at the mall.
"Street Fighter: The Legend of Chin-Li " In Bangkok, crime boss Bison "seriously" reconsiders his life choices.
"Mike and Me!" A story about a man and a "dog."
" Did They Care? (Probably not.)" Everyone\'s wondering about it.
"John\'s " Shopping " Trip " "Jimmy" John Smith goes to "purchase" something.
"The " Proper " Use Of Quotes" Here we discuss how "quotes" should be used.
"Giving It 100%." All about trying hard.
"Mary-Anne, Are You There?" No one can find her.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);