import re
regex = re.compile(r"^ns\-\d{0,4}\.awsdns\-\d\d\.(org|co\.uk|net|com)$", flags=re.MULTILINE)
test_str = ("ns-1354.awsdns-41.org\n"
"ns-1658.awsdns-15.co.uk\n"
"ns-52.awsdns-06.com\n"
"ns-807.awsdns-36.net\n\n"
"ns-1658.awsdns-15.co.uk\n"
"ns-52.awsdns-06.com\n"
"ns-807.awsdns-36.net\n"
"ns-1354.awsdns-41.org\n\n"
"ns.domaincontrol.com\n"
"ns-1.awsdns-36.net\n"
"ns.google.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")