import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9][a-zA-Z0-9äöüÄÖÜß]*@[\\wäöüÄÖÜß][äöüÄÖÜß\\w.-]+\\.[a-z]{2,4}$";
final String string = "a@gmail.de\n"
+ "ab@gmail.de\n"
+ "abc@gmail.de\n"
+ "abcdefggggggggggggg@gmail.de\n"
+ "ä@gmail.de";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}