re = /^[a-zA-Z0-9][a-zA-Z0-9äöüÄÖÜß]*@[\wäöüÄÖÜß][äöüÄÖÜß\w.-]+\.[a-z]{2,4}$/m
str = 'a@gmail.de
ab@gmail.de
abc@gmail.de
abcdefggggggggggggg@gmail.de
ä@gmail.de'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end