$re = '/[a-z]+[0-9]*[_.-]?[a-z0-9]+$/m';
$str = 'gabriel.perezguerra';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);