package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+\b`)
var str = `1234 Вам пришло 3 письма от Васи78
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}