$re = '/\b\d+\b/mu';
$str = '1234 Вам пришло 3 письма от Васи78
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);