using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" \K(?:alt|title|src|href)=[""']?[^>""']+[""']?>??";
string input = @"<anytag aa=""att1"">DESC 1</anytag>
<item aa=""att2"">DESC 2</item>
<anytag bb=""att3"">DESC 3</anytag>
<anytag alt=att4>DESC 4</anytag>
<anytag src=""att5"">DESC 5</anytag>
<anytag src=""att6"">DESC 6</anytag>
<anytag src='att7'>DESC 7</anytag>
<anytag src='att8'>DESC 8</anytag>
<anytag href=""att9"" title=""title1"">DESC 9</anytag>
<anytag blabla=""att10"">DESC 10</anytag>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}