#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[putdn]"
Local $sString = "p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip" & @CRLF & _
"p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip" & @CRLF & _
"p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA_A_N10_packageName" & @CRLF & _
"p_SPEC.operation.Delta_v13.0_20181110_D1_sourceSystemA.zip" & @CRLF & _
"p_SPEC.Delta_v13.0_20181110_D1_sourceSystemA.zip" & @CRLF & _
"p_SPEC.Delta_v13.0_20181110_D1.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")