package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)field=['"](.+?)['"]`)
var str = `{{code field='mail' type='news'}}
{{code field="mail" type='news'}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}