re = /field=['"](.+?)['"]/m
str = '{{code field=\'mail\' type=\'news\'}}
{{code field="mail" type=\'news\'}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end