$re = '/(?<=https?://)(?:\w+\.)+(?<domain>\w+\.\w+)[/\s$]/m';
$str = 'https://www.subdomain.example.com/folder/folder
valid.domains.below
schools.k12
newTLD.clothing text thtat should not be matched
good.photography
x.a-b.com
x-y.a-b.net
x-y.a-b-c.co.uk
x.0ac.com
schools.k12
newTLD.clothing
good.photography
0-1-2.3-4.co
a-----b.com
hello he.llo-o.com/okayokay/
https://www.11737.se/hello/
http://www.11377.se/hello/
www.11773.se/hello/
invalid-.domains for fun
-domain.com
domain--.com
-domain-.-.com
domain.000
.domain.net
domain.net.
sub.-domain.com
sub.domain-.com
sub-.domain.com
-sub.domain.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);