# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=https?://)(?:\w+\.)+(?<domain>\w+\.\w+)[/\s$]"
test_str = ("https://www.subdomain.example.com/folder/folder\n\n\n"
"valid.domains.below\n"
"schools.k12 \n"
"newTLD.clothing text thtat should not be matched \n"
"good.photography\n"
"x.a-b.com\n"
"x-y.a-b.net\n"
"x-y.a-b-c.co.uk\n"
"x.0ac.com\n"
"schools.k12\n"
"newTLD.clothing\n"
"good.photography\n"
"0-1-2.3-4.co\n"
"a-----b.com\n\n"
"hello he.llo-o.com/okayokay/\n\n"
"https://www.11737.se/hello/\n\n"
"http://www.11377.se/hello/\n\n"
"www.11773.se/hello/\n\n\n"
"invalid-.domains for fun\n"
"-domain.com\n"
"domain--.com\n"
"-domain-.-.com\n"
"domain.000\n"
".domain.net\n"
"domain.net.\n"
"sub.-domain.com\n"
"sub.domain-.com\n"
"sub-.domain.com\n"
"-sub.domain.com\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.