use strict;
my $str = '<ROW num="381">
<TO>8549672167</TO>
<FROM>8936742582</FROM>
<TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>
</ROW>
<ROW num="382">
<TO>85496741267</TO>
<FROM>8591903412</FROM>
<TIME>5/10/2009 19:49:37</TIME>
<TEXT>Hme</TEXT>
</ROW>
<ROW num="381">
<TO>8549672167412</TO>
<FROM>8936742582</FROM>
<TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>
</ROW>';
my $regex = qr/<ROW[^<]*?>[^<]*<TO>(?=[^<]*412)[^<]*<\/TO>.*?<\/ROW>/smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}