$re = '/<ROW[^<]*?>[^<]*<TO>(?=[^<]*412)[^<]*<\/TO>.*?<\/ROW>/sm';
$str = '<ROW num="381">
<TO>8549672167</TO>
<FROM>8936742582</FROM>
<TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>
</ROW>
<ROW num="382">
<TO>85496741267</TO>
<FROM>8591903412</FROM>
<TIME>5/10/2009 19:49:37</TIME>
<TEXT>Hme</TEXT>
</ROW>
<ROW num="381">
<TO>8549672167412</TO>
<FROM>8936742582</FROM>
<TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>
</ROW>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);