package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|[^A-Z])([A-Z]{3})(?:[^A-Z]|$)`)
var str = `AAAxxxxBBBBBBBxxGGGxxCCCCCCCCDDDDDDDxxxxxHHHxxxxFFF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}