re = /(?:^|[^A-Z])([A-Z]{3})(?:[^A-Z]|$)/
str = 'AAAxxxxBBBBBBBxxGGGxxCCCCCCCCDDDDDDDxxxxxHHHxxxxFFF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end