#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\*?[A-Z][\w' -]*:\s*"
Local $sString = "*Cassidy: What's your name again?" & @CRLF & _
"Chrissie Watkins: Chrissie!" & @CRLF & _
"Cassidy: Where are we going?" & @CRLF & _
"Chrissie: Swimming!" & @CRLF & _
"Cassidy: Slow up, slow down! I'm not drunk! Slow down! Wait I'm coming! I'm" & @CRLF & _
"coming! I'm definitely " & @CRLF & _
"coming! Wait, slow up! I can swim -- just can't walk or dress myself." & @CRLF & _
"Chrissie: Come on in the water!" & @CRLF & _
"Cassidy: Take it easy. Take it easy." & @CRLF & _
"Chrissie: Oh! God help me! God! Argh! God help!" & @CRLF & _
"Cassidy: I'm coming... I'm coming." & @CRLF & _
"Chrissie: It hurts! It hurts! Oh my god! God help me! God please help!" & @CRLF & _
"Martin Brody: How come the sun didn't use to shine in here." & @CRLF & _
"Ellen Brody: We bought the house in the fall, this is summer." & @CRLF & _
"Ellen: Somebody feed the dogs, huh?" & @CRLF & _
"Martin: Right." & @CRLF & _
"Ellen: See the kids?" & @CRLF & _
"Martin: They must be in the backyard." & @CRLF & _
"Ellen: In Amity, you say: yahd."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)