re = /^\*?[A-Z][\w' -]*:\s*/m
str = '*Cassidy: What\'s your name again?
Chrissie Watkins: Chrissie!
Cassidy: Where are we going?
Chrissie: Swimming!
Cassidy: Slow up, slow down! I\'m not drunk! Slow down! Wait I\'m coming! I\'m
coming! I\'m definitely
coming! Wait, slow up! I can swim -- just can\'t walk or dress myself.
Chrissie: Come on in the water!
Cassidy: Take it easy. Take it easy.
Chrissie: Oh! God help me! God! Argh! God help!
Cassidy: I\'m coming... I\'m coming.
Chrissie: It hurts! It hurts! Oh my god! God help me! God please help!
Martin Brody: How come the sun didn\'t use to shine in here.
Ellen Brody: We bought the house in the fall, this is summer.
Ellen: Somebody feed the dogs, huh?
Martin: Right.
Ellen: See the kids?
Martin: They must be in the backyard.
Ellen: In Amity, you say: yahd.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result