#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<input[^>]+(?|name="fb_dtsg"[^>]+value="([^"]+)"|value="([^"]+)"[^>]+name="fb_dtsg")"
Local $sString = "<input name="init" id="init" value="mag_glass" type="hidden">" & @CRLF & _
"<!--" & @CRLF & _
"" & @CRLF & _
"<input name="fb_dtsg" value="AQHF4anP9ASw" autocomplete="off" type="hidden">" & @CRLF & _
"" & @CRLF & _
"-->" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")