$re = '/<input[^>]+(?|name="fb_dtsg"[^>]+value="([^"]+)"|value="([^"]+)"[^>]+name="fb_dtsg")/m';
$str = '<input name="init" id="init" value="mag_glass" type="hidden">
<!--
<input name="fb_dtsg" value="AQHF4anP9ASw" autocomplete="off" type="hidden">
-->
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);