re = /^(?<version>[^-]*)(-*(?<compatibility>.*))?$/m
str = '12.6.2-alpine
12.6.2
12.6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end