// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^_]*$").unwrap();
let string = "a_a_a";
let substitution = "b";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}