import Foundation
let pattern = #"[^_]*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"a_a_a"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"b"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)