$re = '/(?=\S)(?:"[^"]*"|[^",])+/m';
$str = '6000.1, Basic "Internet" abc, 101, NO_VLAN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);