re = /(?=\S)(?:"[^"]*"|[^",])+/m
str = '6000.1, Basic "Internet" abc, 101, NO_VLAN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end