package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{2}\s?(\d{2})\s?([A-Z]{2})\s?(\d{4})`)
var str = `GH 12RZ 9901`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}