$re = '/[A-Z]{2}\s?(\d{2})\s?([A-Z]{2})\s?(\d{4})/m';
$str = 'GH 12RZ 9901';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);