import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(?:\\d(?:\\.\\d+)?\\s*x\\s*)?\\K(?<!\\d)\\d+(?:\\.\\d+)?(?:k?g|m?l)\\b|(?<!\\d)\\d+(?:\\.\\d+)?(?:k?g|m?l)(?=\\s*x\\s*\\d)";
final String string = "product brand A 1237ml Bundle of 6\n"
+ "product milk choc370ML\n"
+ "brand milk Vanilla Flavor 850g\n"
+ "One 2400g, For 0-6 Month-Old Infants\n"
+ "a+...two...6-12months...11.2kg...milk\n"
+ "a+...two...11.2kg 6-12months ..milk\n"
+ "Product 200g (10x2g)\n"
+ "[200g] Product\n"
+ "Product A brand(300g)\n"
+ "Product 200g (20g x 10)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}