package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\d+h)?(\d+m)?(\d+(?:.\d)?s)?|0)$`)
var str = `30s
5m
5m30s
3m3m
3s3m
3m3m3m
0
m
s
1
2
3h
3h0s
3h0m
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}