re = /^((\d+h)?(\d+m)?(\d+(?:.\d)?s)?|0)$/m
str = '30s
5m
5m30s
3m3m
3s3m
3m3m3m
0
m
s
1
2
3h
3h0s
3h0m
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end