$re = '/[ ,\/]+(?=[^(]*\))/m';
$str = '4. [Access Method/Sort for Archived Data, Meta...................4](#Access Method/Sort for Archived Data, Meta)';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;