import re
regex = re.compile(r"[ ,\/]+(?=[^(]*\))", flags=re.MULTILINE)
test_str = "4. [Access Method/Sort for Archived Data, Meta...................4](#Access Method/Sort for Archived Data, Meta)"
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)