re = /(\/){2,}/i
str = '/api/v1/dude/
//api/v1/dude/
/api///v1/dude/
/api/v1//dude//'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end