#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ims)^How to.*optional\):$"
Local $sString = "//Text comes before this.." & @CRLF & _
"" & @CRLF & _
"How to care for Split Leaf Plant" & @CRLF & _
"" & @CRLF & _
"The Split leaf philodendron, also called monstera deliciosa or swiss cheese plant, is a large, popular, easy- care houseplant that is not really in the philodendron family. There is a great deal of confusion about what to call this plant; the various names have become inter-changeable over the years." & @CRLF & _
"" & @CRLF & _
"Here is more info (optional):" & @CRLF & _
"" & @CRLF & _
"//And more text goes here"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")